VPS侦探论坛

标题: lnmp之pureftpd管理面板安装教程[图文] [打印本页]

作者: licess    时间: 2010-4-1 20:20
标题: lnmp之pureftpd管理面板安装教程[图文]
今日安装了http://www.lnmp.org一键安装包(linux,nginx,mysql,php).这个更新的版本带了pureftpd,更好我需要ftp^^.

安装就不说明了,  当你装完lnmp. 运行:/pureftpd.sh  就自动安装pureftpd了.需要注意就是,你要安装unzip,我之前安装失败,就是因为没有unzip.安装unzip命令是:yum install  unzip.

主要说说面板,其实挺简单的,一步一步来.

首先输入  http://你的域名或IP/ftp/install.php.

第一步:检查文件

全部ok.可以下一步了
第二步:选第一个,创建一个新数据库


第三步:输入mysql信息,全部显示ok.证明你的mysql没错.

继续,都是输入mysql信息,和一个mysql数据库

第四步:这个是配置文件,language哪里选择chinese, ftp address 填写你自己的ip信息.其他默认.然后记得 save保存.

第五步:设置管理员密码(默认的密码我不太清楚),输入新的密码,然后按change.

第六步:到了第六步了,把这些灰色的文字复制下来, 覆盖掉/usr/local/pureftpd/pureftpd-mysql.conf 这个文件.

第七步:搞定了.安装完毕.

这是登陆后的信息.


例如我想新建一个用户 aaa,只可以访问 /home/root/
就在右上角新增账号.
账号填写aaa.
密码自己填写
uid,gid 都选www
主目录选择 /home/root/
这样按保存就可以了.
-----------

安装后最好 运行一次命令:/root/pureftpd restart 因为我新建了一个用户,按保存,不能登陆ftp.后来我试试重新启动,就好了.嘎嘎
还有,如果vps挂了或者重启了, ftp就没了,就要登录ssh 运行:/root/pureftpd start
话说,怎么自启动这个啊?.

****************************
执行如下命令加入开机启动:
cat >/etc/init.d/pureftpd.sh<<eof
/root/pureftpd start
eof
update-rc.d pureftpd.sh defaults
Licess PS:最近家里有事发布lnmp之后就没怎么上网,感谢lnmp爱好者们分享经验。

****************************
作者:Raymond@chenweiwen.com
地址:http://www.chenweiwen.com/post/19/
作者: 54wz    时间: 2010-4-5 20:13
请教2个问题:

1、./pureftpd.sh 完成后,http://localhost/ftp/install.php 安装控制面板,能在控制面板中添加新用户,但新用户在IE或GlobalSCAPE中访问FTP服务器,总是提示密码错误,为啥?

2、
  1. 执行如下命令加入开机启动:
  2. cat >/etc/init.d/pureftpd.sh<<eof
  3. /root/pureftpd start
  4. eof
  5. update-rc.d pureftpd.sh defaults
  6. Licess PS:最近家里有事发布lnmp之后就没怎么上网,感谢[url=forum-25-1.html]lnmp爱好者[/url]们分享经验。
复制代码
按照以上操作步骤操作,系统提示找不到命令update-rc.d。
作者: 阿华    时间: 2010-4-9 16:28
我的怎么没有/usr/local/pureftpd这个文件呢?
作者: 54wz    时间: 2010-5-15 23:52
/root/pureftpd restart

  1. Stopping Pure-FTPd...
  2. pure-ftpd: no process killed
  3. Starting Pure-FTPd...
  4. Running: /usr/local/pureftpd/sbin/pure-ftpd --daemonize -A -c50 -B -C5 -D -E -fftp -H -I15 -lmysql:/usr/local/pureftpd/pureftpd-mysql.conf -lunix -L2000:8 -m4 -p20000:30000 -s -U133:022 -u100 -k99 -Z
  5. 421 配置错误: 无效的SQL配置文件: /usr/local/pureftpd/pureftpd-mysql.conf
复制代码

作者: licess    时间: 2010-5-16 00:30
标题: 回复 4# 的帖子
把第六步里面的文字复制下来, 覆盖掉/usr/local/pureftpd/pureftpd-mysql.conf 这个文件的内容
作者: 54wz    时间: 2010-5-18 09:08
原帖由 licess 于 2010-5-16 00:30 发表
把第六步里面的文字复制下来, 覆盖掉/usr/local/pureftpd/pureftpd-mysql.conf 这个文件的内容


已覆盖,我是在局域网内安装的,本教程第四步,IP地址我填127.0.0.1,结果就是这样了。
作者: shazhumaiyou    时间: 2010-5-25 11:53
我的提示530错误,搞不清楚原因了,一步一步按照楼主的教程操作的
之前安装过lnmp 0.3 ,卸载后装的lnmp 0.4,会不会跟这个有关呢?

[11:52:11] WinSock 2.0 -- OpenSSL 0.9.8g 19 Oct 2007
[11:52:14] [右] 正在连接到 173.234.163.17 -> IP=173.234.163.17 PORT=21
[11:52:14] [右] 已连接到 173.234.163.17
[11:52:15] [右] 220---------- 欢迎来到 Pure-FTPd [privsep] ----------
[11:52:15] [右] 220-您是第 1 个使用者,最多可达 50 个连接
[11:52:15] [右] 220-现在本地时间是 11:52。服务器端口: 21。
[11:52:15] [右] 220-这是私人系统 - 不开放匿名登录
[11:52:15] [右] 220-这部主机也欢迎IPv6的连接
[11:52:15] [右] 220 在 15 分钟内没有活动,您被会断线。
[11:52:15] [右] USER shazhumaiyou
[11:52:15] [右] 331 使用者 shazhumaiyou OK. 需要密码.
[11:52:15] [右] PASS (隐藏)
[11:52:18] [右] 530 验证失败,抱歉
[11:52:18] [右] 连接失败
[11:52:18] [右] 正在延迟 120 秒, 之后将尝试第 1 次重新连接


我的问题已解决,参考文档:http://www.gooth.cn/wordpress/?p=613

我把:pure-ftpd.conf 中的 MinUID 值改为2,登录的问题解决了,不知道会不会有其他安全问题。

[ 本帖最后由 shazhumaiyou 于 2010-5-25 12:08 编辑 ]
作者: amehime    时间: 2010-5-26 08:26
我也遇到了2L的问题~~~
之前重启没有设置自动启动pureftp,导致手动启动后出现了530错误
现在已经解决
但是在设置自动启动pureftp的时候出现了

[root@xxx lnmp0.4]# update-rc.d pureftpd.sh defaults
-bash: update-rc.d: command not found


这样的提示。。。
不支持update-rc.d?这个?
作者: xxnimu    时间: 2010-5-27 16:15
顶!!!!!!!!!!!!!!
作者: nsz8126    时间: 2010-5-28 12:03
原帖由 amehime 于 2010-5-26 08:26 发表
我也遇到了2L的问题~~~
之前重启没有设置自动启动pureftp,导致手动启动后出现了530错误
现在已经解决
但是在设置自动启动pureftp的时候出现了

[root@xxx lnmp0.4]# update-rc.d pureftpd.sh defaults
-bash: update- ...


同样的问题,求解~~
作者: licess    时间: 2010-5-28 21:03
标题: 回复 10# 的帖子
update-rc.d 这个命令是针对debian的
centos编辑/etc/rc.d/rc.local 在文件末尾添加上/root/pureftpd start 保存即可。
作者: viridian    时间: 2010-6-13 17:20
/root/pureftpd restart 也重启了

ftp登陆时还是出现530需要密码错误...
作者: licess    时间: 2010-6-14 16:33
标题: 回复 12# 的帖子
检查/usr/local/pureftpd/pureftpd-mysql.conf 和/home/wwwroot/ftp/config.php 文件中mysql信息是否一致和正确。
作者: 54wz    时间: 2010-7-2 19:58
我在内网机器安装,FTP服务器域名我填localhost:21,进入管理界面后增加新用户,重启pureftpd,但是无法访问。这是怎么回事啊。
作者: 54wz    时间: 2010-7-2 20:03
状态:>          [2010-7-2 20:03:18] 正在连接到 FTP 服务器... 192.168.1.2:21 (ip = 192.168.1.2)...
状态:>          [2010-7-2 20:03:18] Socket 已连接。正在等候欢迎消息...
错误:>           [2010-7-2 20:03:19] 无法从控制 Socket 读取。Socket 错误 = #10054。
作者: xiaozhao    时间: 2010-7-13 19:10
受益匪浅,楼主基本每个帖子都用心回复,让人敬佩啊
作者: licess    时间: 2010-7-13 19:48
标题: 回复 16# 的帖子

作者: coollyct    时间: 2010-11-6 16:55
PS:刚又试了一下,又能用了。这真奇怪。

[ 本帖最后由 coollyct 于 2010-11-6 18:38 编辑 ]
作者: muhero    时间: 2010-12-18 12:50
感谢楼主

我按照楼主的方法及方案lnmp0.5及pureftpd都安装成功了,FTP能登录,能上传,但通过FTP链接上后

1、文件不能移动

2、不能修改文件及文件夹权限

另外:按照教程安装时有一个默认的FTP用户及密码,那个安全吗?
作者: lysafe    时间: 2011-12-20 14:48
标题: 回复 3# 的帖子
find / -name pureftpd.sh


/root/lnmp0.7  

以你的版本为准。。。
作者: licess    时间: 2011-12-20 16:46
标题: 回复 19# 的帖子
权限设置问题,文件属主设成www




欢迎光临 VPS侦探论坛 (https://bbs.lnmp.com/) Powered by Discuz! X3.4