VPS侦探论坛

标题: 军哥!如何添加LDAP扩展,按标准方法安装还是不成功 [打印本页]

作者: godfather    时间: 2018-9-28 20:49
标题: 军哥!如何添加LDAP扩展,按标准方法安装还是不成功
我是lnmp1.5环境, php是7.1.18 安装zabbix提示缺少ldap扩展,按你们的标准方法下载lnmp1.5-full包进行安装扩展,到make install一步报如下错:

Warning! a PEAR user config file already exists from a previous PEAR installation at '/root/.pearrc'. You may probably want to remove it.
Wrote PEAR system config file at: /usr/local/etc/pear.conf
You may want to add: /usr/local/lib/php to your php.ini include_path
/usr/local/src/lnmp1.5-full/src/php-7.1.18/build/shtool install -c ext/phar/phar.phar /usr/local/bin
ln -s -f phar.phar /usr/local/bin/phar
Installing PDO headers:           /usr/local/include/php/ext/pdo/

我忽略此报错直接重启php,报如下错:

Starting php-fpm [28-Sep-2018 20:21:07] NOTICE: PHP message: PHP Warning:  PHP Startup: ldap: Unable to initialize module
Module compiled with module API=20100525
PHP    compiled with module API=20160303
These options need to match
in Unknown on line 0
done


麻烦军哥和广大网友给看看!
作者: licess    时间: 2018-9-29 09:02
上面有提示php是7.1,但是你ldap扩展是用php 5.4里的ldap的源码编译安装处理的
作者: godfather    时间: 2018-9-29 09:56
标题: 回复 2# 的帖子
[root@localhost php-7.1.18]# pwd
/usr/local/src/lnmp1.5-full/src/php-7.1.18
这是我的目录,是用的7.1.18的源码啊,那现在改如何处理呢?
作者: licess    时间: 2018-9-29 17:47
标题: 回复 3# 的帖子
删除ldap.so 在php 7.1.18版本ldap源码目录下编译安装
作者: godfather    时间: 2018-9-29 19:01
标题: 回复 4# 的帖子
可能我没表达清楚,我的意思是第一次我就是在7.1.18的源码下编译安装的




欢迎光临 VPS侦探论坛 (https://bbs.lnmp.com/) Powered by Discuz! X3.4