VPS侦探论坛

标题: 站点 500 错误 [打印本页]

作者: ericec    时间: 2020-8-18 20:06
标题: 站点 500 错误
## 背景


1. 今天在更新 ssh 证书,结果把网站弄成 500 了。
2. 后面手动调整了 ng 配置文件,没救回来。
3. 其他什么都没动过。

手动启动/停止 php-fpm 报错。

service php-fpm stop
Gracefully shutting down php-fpm warning,no pid file found – php-fpm is not running?
网搜说是 PID 值不一样,不过我没手动调整过这些内容,没想明白。部分排查按照pnmp.org 的排查帖子处理过,原先建站的时候数值都调整过。
尝试过运行 ./check502.sh,不过没有任何信息反馈。


作者: licess    时间: 2020-8-19 08:31
500一般和nginx配置文件没有关系,按常见问题开启php错误日志看一下

service php-fpm stop
Gracefully shutting down php-fpm warning,no pid file found – php-fpm is not running?
如果你php-fpm已经停止再去stop肯定是这个错误提示

500和502完全不一样所有502的方法不适于500,按前面我说的开php错误日志
作者: ericec    时间: 2020-8-19 12:11
错误日志已上传,麻烦军哥帮忙看一下
作者: licess    时间: 2020-8-19 19:13
ericec 发表于 2020-8-19 12:11
错误日志已上传,麻烦军哥帮忙看一下

这个不是php错误日志,而是是php-fpm日志,常见问题有php错误日志的开启方法
作者: ericec    时间: 2020-8-20 18:58
按教程操作了,但是 php_errors.log 一直是一个 0kb 的空文件
作者: ericec    时间: 2020-8-20 19:02
重启 ng 后现在变成 502 错误了。
作者: ericec    时间: 2020-8-20 19:05
还是怀疑问题出在 php-pm 上。运行 /etc/init.d/php-fpm restart 会报如下错

[root@izbp19ejlbzh5g8af4spxlz ~]# /etc/init.d/php-fpm restart
Gracefully shutting down php-fpm warning, no pid file found - php-fpm is not running ?
Starting php-fpm /usr/local/php/sbin/php-fpm: error while loading shared libraries: libsqlite3.so.0: cannot open shared object file: No such file or directory
failed



作者: ericec    时间: 2020-8-20 19:16
[root@izbp19ejlbzh5g8af4spxlz ~]# lnmp php-fpm start
+-------------------------------------------+
|    Manager for LNMP, Written by Licess    |
+-------------------------------------------+
|              https://lnmp.org             |
+-------------------------------------------+
Starting php-fpm /usr/local/php/sbin/php-fpm: error while loading shared libraries: libsqlite3.so.0: cannot open shared object file: No such file or directory
failed
作者: licess    时间: 2020-8-20 20:30
ericec 发表于 2020-8-20 19:05
还是怀疑问题出在 php-pm 上。运行 /etc/init.d/php-fpm restart 会报如下错

[root@izbp19ejlbzh5g8af4spx ...

0kb可能是没有访问500站点

Starting php-fpm /usr/local/php/sbin/php-fpm: error while loading shared libraries: libsqlite3.so.0: cannot open shared object file: No such file or directory
这个是因为你系统上原来的依赖包 sqlite-devel 或 libsqlite3-dev 被卸载了,重新安装就可以了,使用yum或apt-get install 对应前面的依赖包就行了




欢迎光临 VPS侦探论坛 (https://bbs.lnmp.com/) Powered by Discuz! X3.4