VPS侦探论坛

 找回密码
 注册
查看: 2981|回复: 4

请教一下大家lnmp1.3-full php打补丁问题

[复制链接]
发表于 2017-9-8 15:07:36 | 显示全部楼层 |阅读模式

新手  领导发现漏洞 需要php打补丁  看了下 方法都是源码安装的发现  、我想问下 咱这个能不能按源码的方法来  就是
先到lnmp1.3-full/src  解压对应安装的php文件 然后进去 patch  补丁   
最后  upgrade.sh  php    版本号写当前对应的版本号  也就是重新安装一模一样的 只不过这个打了补丁


不知道这样对不对  请教一下各位大神和军哥
我的php版本为5.4.35

[ 本帖最后由 ll171218353 于 2017-9-8 15:34 编辑 ]
美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2017-9-8 15:34:23 | 显示全部楼层


我的php版本为 5.4.35
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2017-9-8 19:19:32 | 显示全部楼层

使用upgarde.sh 进行升级的话 修改 include/upgarde_php.sh 修改里面对应php版本的./configure 前添加相关打补丁的命令
美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2017-11-8 15:08:31 | 显示全部楼层

回复 3# 的帖子




谢谢了 当时自己解决了 也忘记来这里看了
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2024-5-15 14:21:43 | 显示全部楼层

licess 发表于 2017-9-8 19:19
使用upgarde.sh 进行升级的话 修改 include/upgarde_php.sh 修改里面对应php版本的./configure 前添加相关 ...

有php打补丁的详细教程吗?只打补丁,不升级版本

军哥运维代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2024-5-27 10:45 , Processed in 0.038088 second(s), 16 queries .

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表