VPS侦探论坛

 找回密码
 注册
查看: 1058|回复: 1

腾讯云os安装lnmp,php8.1失败

[复制链接]
发表于 2023-5-12 17:40:46 | 显示全部楼层 |阅读模式


日志:https://t.wss.ink/f/b6w82091prz 复制链接到浏览器打开

腾讯云os,4核4G。
美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2023-5-13 21:05:53 | 显示全部楼层


Last metadata expiration check: 0:00:56 ago on Fri 12 May 2023 02:12:45 PM CST.
Error:
Problem: package libxslt-devel-1.1.32-6.el8.x86_64 requires pkgconfig(libxml-2.0), but none of the providers can be installed
  - package libxml2-devel-2.9.7-9.el8_4.2.x86_64 requires xz-devel(x86-64), but none of the providers can be installed
  - package libxml2-devel-2.9.7-9.el8_4.2.i686 requires zlib-devel(x86-32), but none of the providers can be installed
  - package xz-devel-5.2.4-3.el8.x86_64 requires xz-libs(x86-64) = 5.2.4-3.el8, but none of the providers can be installed
  - zlib-devel-1.2.11-17.el8.i686 has inferior architecture
  - cannot install both xz-libs-5.2.4-3.el8.x86_64 and xz-libs-5.2.4-4.oc8.x86_64
  - cannot install both zlib-devel-1.2.11-17.el8.x86_64 and zlib-devel-1.2.11-21.oc8.x86_64
  - package xz-5.2.4-4.oc8.x86_64 requires xz-libs(x86-64) = 5.2.4-4.oc8, but none of the providers can be installed
  - package zlib-static-1.2.11-21.oc8.x86_64 requires zlib-devel(x86-64) = 1.2.11-21.oc8, but none of the providers can be installed
  - package xz-lzma-compat-5.2.4-4.oc8.x86_64 requires xz(x86-64) = 5.2.4-4.oc8, but none of the providers can be installed
  - cannot install the best candidate for the job
  - problem with installed package zlib-static-1.2.11-21.oc8.x86_64
  - problem with installed package xz-lzma-compat-5.2.4-4.oc8.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

。。。。。。

checking for libxml-2.0 >= 2.9.0... no
configure: error: Package requirements (libxml-2.0 >= 2.9.0) were not met:

Package 'libxml-2.0', required by 'virtual:world', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBXML_CFLAGS
and LIBXML_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

首先OpenCloudOS 8.6暂未加入支持,直接通过修改脚本识别成centos的话会有问题

yum install libxml2-devel --allowerasing 看一下能否修复,能修复的话把其他几个上面的软件包也都修复

最最简单的方法换Debian
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2024-5-23 18:14 , Processed in 0.024884 second(s), 16 queries .

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表