VPS侦探论坛

 找回密码
 注册
查看: 904|回复: 1

linux使用lnmp2.0一键安装包安装失败

[复制链接]
发表于 2023-10-19 09:23:45 | 显示全部楼层 |阅读模式

使用 wget https://soft.lnmp.com/lnmp/lnmp2.0.tar.gz -O lnmp2.0.tar.gz && tar zxf lnmp2.0.tar.gz && cd lnmp2.0 && ./install.sh lnmp    报错如下:
Checking ...
Error: Nginx install failed.
Error: MySQL install failed.
Error: PHP install failed.
Sorry, Failed to install LNMP!
Please visit https://bbs.vpser.net/forum-25-1.html feedback errors and logs.
You can download /root/lnmp-install.log from your server,and upload lnmp-install.log to LNMP Forum.

uname -a:Linux localhost.localdomain 3.10.0-1160.71.1.el7.x86_64 #1 SMP Tue Jun 28 15:37:28 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
cat /etc/centos-release:CentOS Linux release 7.9.2009 (Core)
lnmp版本:2.0
报错lnmp-install.log:https://t.wss.ink/f/cggv70ryw7n 复制链接到浏览器打开

是空的服务器,安装步骤:
1、登陆后运行:screen -S lnmp
2、运行:
wget https://soft.lnmp.com/lnmp/lnmp2.0.tar.gz -O lnmp2.0.tar.gz && tar zxf lnmp2.0.tar.gz && cd lnmp2.0 && ./install.sh lnmp
3、Install MySQL  5.7.38  选择了 4
4、Using Generic Binaries [y/n]    选了 n
5、设置mysql密码
6、
启用MySQL InnoDB
7、
Install PHP 7.2.34 选了 8
8、是否安装内存优化  选了 2 Install Jemalloc
9、
"Press any key to install...or Press Ctrl+c to cancel"后,按回车键确认开始安装

然后等待安装结果:都安装失败,想问下是什么原因导致的?


美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2023-10-23 08:16:53 | 显示全部楼层


正在解决依赖关系
--> 正在检查事务
---> 软件包 gcc.x86_64.0.4.8.5-44.el7 将被 安装
--> 正在处理依赖关系 cpp = 4.8.5-44.el7,它被软件包 gcc-4.8.5-44.el7.x86_64 需要
--> 正在处理依赖关系 glibc-devel >= 2.2.90-12,它被软件包 gcc-4.8.5-44.el7.x86_64 需要
--> 正在处理依赖关系 libmpfr.so.4()(64bit),它被软件包 gcc-4.8.5-44.el7.x86_64 需要
--> 正在处理依赖关系 libmpc.so.3()(64bit),它被软件包 gcc-4.8.5-44.el7.x86_64 需要
--> 正在检查事务
---> 软件包 cpp.x86_64.0.4.8.5-44.el7 将被 安装
---> 软件包 glibc-devel.x86_64.0.2.17-317.el7 将被 安装
--> 正在处理依赖关系 glibc-headers = 2.17-317.el7,它被软件包 glibc-devel-2.17-317.el7.x86_64 需要
--> 正在处理依赖关系 glibc = 2.17-317.el7,它被软件包 glibc-devel-2.17-317.el7.x86_64 需要
--> 正在处理依赖关系 glibc-headers,它被软件包 glibc-devel-2.17-317.el7.x86_64 需要
---> 软件包 libmpc.x86_64.0.1.0.1-3.el7 将被 安装
---> 软件包 mpfr.x86_64.0.3.1.1-4.el7 将被 安装
--> 正在检查事务
---> 软件包 glibc.i686.0.2.17-317.el7 将被 安装
--> 正在处理依赖关系 glibc-common = 2.17-317.el7,它被软件包 glibc-2.17-317.el7.i686 需要
--> 正在处理依赖关系 libfreebl3.so(NSSRAWHASH_3.12.3),它被软件包 glibc-2.17-317.el7.i686 需要
--> 正在处理依赖关系 libfreebl3.so,它被软件包 glibc-2.17-317.el7.i686 需要
---> 软件包 glibc-headers.x86_64.0.2.17-317.el7 将被 安装
--> 正在检查事务
---> 软件包 glibc.i686.0.2.17-317.el7 将被 安装
--> 正在处理依赖关系 glibc-common = 2.17-317.el7,它被软件包 glibc-2.17-317.el7.i686 需要
---> 软件包 nss-softokn-freebl.i686.0.3.44.0-8.el7_7 将被 安装
--> 解决依赖关系完成
错误:软件包:glibc-2.17-317.el7.i686 (base)
          需要:glibc-common = 2.17-317.el7
          已安装: glibc-common-2.17-326.el7_9.x86_64 (@anaconda)
              glibc-common = 2.17-326.el7_9
          可用: glibc-common-2.17-317.el7.x86_64 (base)
              glibc-common = 2.17-317.el7
您可以尝试添加 --skip-broken 选项来解决该问题
您可以尝试执行:rpm -Va --nofiles --nodigest

按错误信息的话应该是系统源设置有问题,先设置好系统源,然后再按 https://bbs.lnmp.com/thread-26066-1-1.html 操作一下
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2024-3-2 09:19 , Processed in 0.026389 second(s), 16 queries .

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表