VPS侦探论坛

 找回密码
 注册
查看: 383|回复: 4

LNMP2.0 安装swoole失败

[复制链接]
发表于 2023-12-4 09:42:42 | 显示全部楼层 |阅读模式

本帖最后由 1239207847 于 2023-12-4 09:52 编辑

系统版本:CentOS  7.9

LNMP2.0
安装了PHP7.4.33和PHP8.2

使用
  1. ./addons.sh install swoole
复制代码
美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2023-12-4 09:44:05 | 显示全部楼层


报错信息
  1. In file included from /root/lnmp2.0/src/swoole-5.0.3/ext-src/php_swoole_cxx.h:19:0,
  2.                  from /root/lnmp2.0/src/swoole-5.0.3/ext-src/php_swoole.cc:16:
  3. /root/lnmp2.0/src/swoole-5.0.3/ext-src/php_swoole_private.h:96:2: error: #error "require PHP version 8.0 or later"
  4. #error "require PHP version 8.0 or later
复制代码
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
 楼主| 发表于 2023-12-4 09:50:17 | 显示全部楼层


swoole5.x版本支持PHP8,所以报错,脚本应该加一个判断
美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
 楼主| 发表于 2023-12-4 09:53:29 | 显示全部楼层



1239207847 发表于 2023-12-4 09:50
swoole5.x版本支持PHP8,所以报错,脚本应该加一个判断

PHP7.4安装swoole报错
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
发表于 2023-12-6 10:45:52 | 显示全部楼层

include/version.sh 改一下swoole版本号,php 7.4的时候改成4.8.13,php 8的时候改成5.1.1,需要自行下载好对应版本的源码包到安装包src目录下

军哥运维代购:http://shop63846532.taobao.com/

您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2024-3-2 07:44 , Processed in 0.026530 second(s), 16 queries .

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表