VPS侦探论坛

 找回密码
 注册
查看: 310|回复: 1

lnmp1.7升级php出错,不能安装,没确认到问题点。

[复制链接]
发表于 2023-12-12 15:30:46 | 显示全部楼层 |阅读模式

网站运行很久了,最近因要更新,升级到php8,运行 ./upgrade.sh 卸载了原来的php,新的没装上,很奇怪。



lnmp1.7# ./upgrade.sh

Current PHP Version:7.2.34
You can get version number from http://www.php.net/
Please enter a PHP Version you want: 8.0.26
Saving to: ‘php-8.0.26.tar.bz2’
100%[======================================>] 13,646,335  9.09MB/s   in 1.4s

Download php-8.0.26.tar.bz2 successfully!
Stoping LNMP...
Stoping nginx...  done
Shutting down MySQL
.... *
Gracefully shutting down php-fpm . done
Installing Dependent for PHP...
Ign http://mirrors.aliyun.com trusty InRelease
Hit http://mirrors.aliyun.com trusty-updates InRelease
Hit http://mirrors.aliyun.com trusty-security InRelease
Hit http://mirrors.aliyun.com trusty Release.gpg
Hit http://mirrors.aliyun.com trusty-updates/main Sources
Hit http://mirrors.aliyun.com trusty-updates/universe Sources
Hit http://mirrors.aliyun.com trusty-updates/main amd64 Packages
Hit http://mirrors.aliyun.com trusty-updates/universe amd64 Packages
Hit http://mirrors.aliyun.com trusty-updates/main i386 Packages
Hit http://mirrors.aliyun.com trusty-updates/universe i386 Packages
Hit http://repo.zabbix.com trusty InRelease
Hit http://mirrors.aliyun.com trusty-updates/main Translation-en
Hit http://mirrors.aliyun.com trusty-updates/universe Translation-en
Hit http://mirrors.aliyun.com trusty-security/main Sources
Hit http://repo.zabbix.com trusty/main Sources
Hit http://mirrors.aliyun.com trusty-security/universe Sources
Hit http://mirrors.aliyun.com trusty-security/main amd64 Packages
Ign http://repo.mongodb.org trusty/mongodb-org/3.2 InRelease
Hit http://mirrors.aliyun.com trusty-security/universe amd64 Packages
Hit http://repo.zabbix.com trusty/main amd64 Packages
Hit http://mirrors.aliyun.com trusty-security/main i386 Packages
Hit http://mirrors.aliyun.com trusty-security/universe i386 Packages
Hit http://mirrors.aliyun.com trusty-security/main Translation-en
Hit http://repo.mongodb.org trusty/mongodb-org/3.2 Release.gpg
Hit http://repo.zabbix.com trusty/main i386 Packages
Hit http://mirrors.aliyun.com trusty-security/universe Translation-en
Hit http://mirrors.aliyun.com trusty Release
Hit http://mirrors.aliyun.com trusty/main Sources
Hit http://mirrors.aliyun.com trusty/universe Sources
Hit http://mirrors.aliyun.com trusty/main amd64 Packages
Hit http://repo.mongodb.org trusty/mongodb-org/3.2 Release
Hit http://mirrors.aliyun.com trusty/universe amd64 Packages
Hit http://mirrors.aliyun.com trusty/main i386 Packages
Hit http://mirrors.aliyun.com trusty/universe i386 Packages
Hit http://mirrors.aliyun.com trusty/main Translation-en
Hit http://repo.mongodb.org trusty/mongodb-org/3.2/multiverse amd64 Packages
Hit http://mirrors.aliyun.com trusty/universe Translation-en
Hit http://repo.mongodb.org trusty/mongodb-org/3.2/multiverse i386 Packages
Ign http://mirrors.aliyun.com trusty/main Translation-en_US
Ign http://mirrors.aliyun.com trusty/universe Translation-en_US
Ign http://repo.zabbix.com trusty/main Translation-en_US
Ign http://repo.zabbix.com trusty/main Translation-en
Ign http://repo.mongodb.org trusty/mongodb-org/3.2/multiverse Translation-en_US
Ign http://repo.mongodb.org trusty/mongodb-org/3.2/multiverse Translation-en
Ign https://esm.ubuntu.com trusty-infra-security InRelease
Ign https://esm.ubuntu.com trusty-infra-updates InRelease
Ign https://esm.ubuntu.com trusty-infra-security Release.gpg
Get:1 https://esm.ubuntu.com trusty-infra-updates Release.gpg
Get:2 https://esm.ubuntu.com trusty-infra-security Release
Get:3 https://esm.ubuntu.com trusty-infra-updates Release
Get:4 https://esm.ubuntu.com trusty-infra-security/main amd64 Packages/DiffIndex
Ign https://esm.ubuntu.com trusty-infra-security/main amd64 Packages/DiffIndex
Ign https://esm.ubuntu.com trusty-infra-security/main i386 Packages/DiffIndex
Get:5 https://esm.ubuntu.com trusty-infra-updates/main i386 Packages
Get:6 https://esm.ubuntu.com trusty-infra-updates/main Translation-en_US
Get:7 https://esm.ubuntu.com trusty-infra-security/main i386 Packages
Get:8 https://esm.ubuntu.com trusty-infra-security/main Translation-en_US
Ign https://esm.ubuntu.com trusty-infra-security/main Translation-en_US
Ign https://esm.ubuntu.com trusty-infra-security/main Translation-en
Ign https://esm.ubuntu.com trusty-infra-updates/main Translation-en_US
Ign https://esm.ubuntu.com trusty-infra-updates/main Translation-en
Fetched 1,372 kB in 43s (31.4 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
libc-ares-dev is already the newest version.
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libicu-dev is already the newest version.
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
e2fsprogs is already the newest version.
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libxslt1.1 is already the newest version.
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libxslt1-dev is already the newest version.
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libc-client2007e-dev is already the newest version.
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
xz-utils is already the newest version.
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libexpat1-dev is already the newest version.
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
bzip2 is already the newest version.
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
libonig-dev is already the newest version.
The following package was automatically installed and is no longer required:
  libreadline5
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
(dod-website) root@dod-db146:~/lnmp1.7# apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  libreadline5
0 upgraded, 0 newly installed, 1 to remove and 3 not upgraded.
After this operation, 370 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 125017 files and directories currently installed.)
Removing libreadline5:amd64 (5.2+dfsg-2) ...
Processing triggers for libc-bin (2.19-0ubuntu6.15) ...


美国VPS推荐: 遨游主机LinodeLOCVPS主机云搬瓦工80VPSVultr美国VPS主机中国VPS推荐: 阿里云腾讯云。LNMP付费服务(代装/问题排查)QQ 503228080
发表于 2023-12-14 09:00:04 | 显示全部楼层


lnmp 1.7不支持php 8,所以没法升级,只有支持的版本才能用升级脚本进行升级
Linux下Nginx+MySQL+PHP自动安装工具:https://lnmp.org
您需要登录后才可以回帖 登录 | 注册

本版积分规则

小黑屋|手机版|Archiver|VPS侦探 ( 鲁ICP备16040043号-1 )

GMT+8, 2024-3-2 09:18 , Processed in 0.026757 second(s), 16 queries .

Powered by Discuz! X3.4

© 2001-2023 Discuz! Team.

快速回复 返回顶部 返回列表